Forums » Songs » Dance Pad completely stops responding 10 seconds into song

Hi SM community. I feel I'm at a last resort situation. I've been enjoying SM for years, using the same laptop/adapter/metal dance pad. A couple months ago a thief stole the laptop and the last of my spare replacement plastic arrows!

Fast forward to last week. I get another pc, clean install of XP (and later formatted for Windows 7), hooked everything up, loaded SM3.9 (and also tried 3.9 redux), started playing and the dance mat stopped accepting button presses about 10 seconds into actually playing a song. Now I can't for the life of me figure out what is happening.

I've tried SM3.9 in Windows 7.
I've tried SM3.9 redux in Windows 7.
I've tried SM3.9 in Windows XP.
I've tried SM3.9 redux in Windows XP.

I even bought a replacement PS2 to USB Adapter, and I'm getting the exact same results. Once the controller/mat goes dead it will not respond until I unplug it from USB and reconnect it (however it is still getting power since the arrow LED's still light up, even though the button presses do nothing on screen). After doing that, the computer finds the new hardware, finds the driver (just like it did before), and it starts working again.

I really don't know where to go at this point and any help would be greatly appreciated. So much so that I'll paypal anyone that can help $5 for their guidance/trouble.

Side note: My original adapter which worked great for years was the Mayflash Joy Box 3 Pro. The new one I bought was also Mayflash, its designed to work with dance pads specifically.

I removed the LED's from the dance panels thinking the replacement (panels with LEDs) somehow acted differently than the ones that originally came with the pad.

Still seems to have the issue. Although I was able to play 5-6 songs before it failed again. I'm thinking maybe the circuit board inside the pad has something loose? Really grasping at straws here.
I've had the same problem with a metal pad and the solution for me was to take off my shoes and continue play as normal. I wished it wasn't like this but it probably had something to do with putting too much force on the pad buttons.

(The pad was metal and the buttons were plastic-like.)

Last edited: 19 May 2017 1:55pm