Forums » General Questions » Tried to install theme, SM5 crashes even after reinstall on MAC

I realize now the theme won't work on 5, that's fine. I appear to have deleted all the files but of course they are still coming in the the errors even after trying to reinstall. Not sure what to do at this point.

Architecture: Mac OS X (i386)
Crash reason: Assertion 'v.size() > 0' failed
Crashed thread: Main thread

Thread: GUI thread
Thread: Main thread
IniFile.cpp:21 Reading 'Themes/DDR EXTREME/Languages/en.ini'
IniFile.cpp:21 Reading 'Themes/_fallback/metrics.ini'
IniFile.cpp:21 Reading 'Themes/_fallback/Languages/en.ini'
IniFile.cpp:21 Reading 'Themes/_fallback/ThemeInfo.ini'
CommonMetrics.cpp:41 Assertion 'v.size() > 0' failed

00292b0b: CrashHandler::ForceCrash(char const*)
00331b4d: sm_crash(char const*)
003cb109: ThemeMetricDifficultiesToShow::Read()
002575db: ThemeManager::SwitchThemeAndLanguage(StdString::CStdStr<char> const&, StdString::CStdStr<char> const&, bool, bool)
000c46a6: StepMania::ChangeCurrentGame(Game const*)
000c591e: SM_main
0044069b: std::_Rb_tree<LocalizedString*, LocalizedString*, std::_Identity<LocalizedString*>, std::less<LocalizedString*>, std::allocator<LocalizedString*> >::_M_insert_unique(LocalizedString* const&)

Static log:
StepMania v5.0 beta 3
Compiled Mon Feb 24 15:07:47 EST 2014 @ (build 35)
Log starting 2014-10-03 02:40:04
Loading window: macosx
Model: MacBookPro9,2 (4/4)
Clock speed 2.50 GHz
Mac OS X 10.9.4
Memory: 4.00 GB
Language: en

Partial log:
00:00.246: Loading "/Themes/_fallback/Scripts/02 ThemePrefs.lua" ...
00:00.246: Loading "/Themes/_fallback/Scripts/02 ThemePrefsRows.lua" ...
00:00.246: Loading "/Themes/_fallback/Scripts/02 Utilities.lua" ...
00:00.247: Loading "/Themes/_fallback/Scripts/03 CustomSpeedMods.lua" ...
00:00.248: Loading "/Themes/_fallback/Scripts/03 Gameplay.lua" ...
00:00.248: Loading "/Themes/_fallback/Scripts/03 GamePreferences.lua" ...
00:00.248: Loading "/Themes/_fallback/Scripts/03 ThemeAndGamePrefs.lua" ...
00:00.249: Loading "/Themes/_fallback/Scripts/03 ThemeLibrary.lua" ...
00:00.249: Loading "/Themes/_fallback/Scripts/03 UserPreferences2.lua" ...
00:00.249: Reading 'Themes/_fallback/ThemeInfo.ini' failed: No such file or directory

-- End of report
So, exactly what did you delete when you removed the theme? Did you only delete the "DDR EXTREME" folder, or did you delete other folders too?
Also, when you installed it, did you put it in the main Stepmania folder like older versions may have told you to do, or did you put it in "~/Library/Application Support/StepMania 5/Themes/" the way the Docs link above says to?
At this point, I'm just trying to figure out exactly what you did, before figuring out what to do to fix it.

As an aside, SM5 Beta 4 was released 2 days ago (and the downloads page hasn't been updated yet), but Beta 4 probably won't fix your problem.

Last edited: 3 October 2014 1:52am

< cybik> til Kyzentun fixes bugs for breakfast
< maxvg1> shakesoda: then why do i still play lol
<@shakesoda> because you're an ITG player. And thus, a masochist
<@shakesoda> Kyzentun: I think you might need to put down the meshes for a bit
I deleted everything to my knowledge not just the theme. I tried to put it right in the step mania folder. I am searching on my computer but I can't seem to find any left over app files for SM. Hmmmmm.
Never fear I used a third party app to get rid of all previous data associated with it. All working now. Thanks!
Never fear I used a third party app to get rid of all previous data associated with it.
I am admittedly afraid of trusting third party apps that offer to clean my operating system, but I'm glad it works.