Forums » General Questions » SM5 "choppy" arrows problem

1
NOTE: This is already solved. See one of my posts below to fix this problem.

I've had this problem since I first tested out SM5 (sm-ssc). Whenever I play a song in StepMania, the arrows jitter or look choppy as they're moving. StepMania still reports a FPS of 60, but the arrows look like if they were refreshing with a lower framerate. This didn't happen at all in StepMania 3.9 on Windows XP.

I can semi-fix this problem by disabling vertical sync on my graphic's card configuration, but then StepMania runs at about 300+ FPS and screen tearing becomes another problem.

This is a common issue with StepMania on Windows Vista, 7 and superior, and also on Linux (Ubuntu, etc.). Any solutions?

Last edited: 7 December 2016 4:19pm

Reply
If you haven't already, hold F3 and hit 6 to enable the fps counter on the screen and watch it through a song with autoplay.
I don't think there's a real solution to this, since I think the underlying cause is that so much of the game logic occurs in the graphics thread (unverified intuition).
One thing you could try is just run at a higher resolution to lower the frame rate when not forcing vertical sync. I run at 1920x1200 on a computer from 2011 and I get 100-120 fps during gameplay unless the streams are dense. (number of arrows on screen makes a substantial difference)
I tend to be blind to things like tearing though, and I'm on an LCD.
< cybik> til Kyzentun fixes bugs for breakfast
--
< maxvg1> shakesoda: then why do i still play lol
<@shakesoda> because you're an ITG player. And thus, a masochist
--
<@shakesoda> Kyzentun: I think you might need to put down the meshes for a bit
Reply
Yeah, still says it's 60 fps. It's kind of weird... and I'm already running at my monitor's native resolution and hertz (1360x768, 60 Hz) by the way.

Last edited: 17 August 2014 8:26pm

Reply
I'm bumping this topic because I have found a solution. It was related to the sound driver/device.

Problem:

The arrows stutter or look laggy as if they were skipping frames (even when StepMania says it's running at 60 FPS).

Solution:

In the file Preferences.ini , you need to change a setting related to the audio driver. This file is located in %AppData%\StepMania 5\Save under Windows, and /home/<username>/.stepmania-5.0/Save under Linux.

Windows: This issue usually occurs in Windows Vista and newer. Change the entry "SoundDriver" as follows:

SoundDrivers=WaveOut

Linux: Change the "SoundDevice" as follows:

SoundDevice=hw:0


If the SoundDevice doesn't work, try changing the 0 to a different number, eg. 1, 2, etc.
This is because ALSA may assign the HDMI sound output to 0 (only on certain motherboards with HDMI), which is probably not what you want.


Another solution for Linux is to use the "oss" backend for audio. Since most Linux distributions use ALSA or PulseAudio by default, you can just install the "osspd" package to have support for OSS (albeit emulated).

For Debian, Ubuntu and related distributions:

sudo apt-get install osspd


------------------

These changes may not be noticeable if VSync is turned OFF. You need to turn VSync ON in both inside StepMania and your graphics card configuration.
I recommend running the "Calibrate audio sync" option again, because this also fixes the timing between the arrows and the songs (global offset should be set to 0 as a recommendation).

Hope this helps other people having the same issue.

Last edited: 21 June 2020 8:40pm

Reply


I made an account just to thank you for this post.
This did the trick for me.
Xoxo
Reply