Forums » General Questions » installing SM5b3 Linux

I ran those commands. Here is the terminal output:

StepMania v5.0 beta 3
Compiled 20140408 @ 02:46:15 PM MDT (UTC-06:00) (build 0)
Log starting 2014-04-08 16:16:31
Couldn't load driver gtk: dlopen(): /home/user/stepmania/ cannot open shared object file: No such file or directory
Error: Couldn't open any loading windows.

Last edited: 8 April 2014 5:39pm

Try copying that out of the src dir too, that might work.
< cybik> til Kyzentun fixes bugs for breakfast
< maxvg1> shakesoda: then why do i still play lol
<@shakesoda> because you're an ITG player. And thus, a masochist
<@shakesoda> Kyzentun: I think you might need to put down the meshes for a bit
Yup, that did it. Thanks guys!
Idk when you plan on updating the install page, but here's what worked for me, should work for whoever needs it.

In terminal, enter the folliwing commands:

sudo apt-get install libasound2-dev libpulse-dev libmad0-dev libtheora-dev libvorbis-dev libpng-dev libswscale-dev libavutil-dev libavformat-dev libavcodec-dev libjpeg-dev libglu1-mesa-dev libgl1-mesa-dev libgtk2.0-dev xorg-dev libxrandr-dev libbz2-dev libglew1.5-dev automake1.10 build-essential curl g++ yasm subversion glew-utils libglew-dev libglewmx1.8 libglewmx-dev libglew1.8 git

git clone

cd stepmania


./configure --verbose &> conf.out



cp src/stepmania ./

chmod +x *.desktop

*use your file manager's search feature to find it's there somewhere, but it needs to be copied to the stepmania parent folder.
Then you should be done. just load some songs, and you're good to go. If not, I can't help :P

Thanks a lot for your help guys, great revision of SM5.
I love your avatars, btw.

Last edited: 9 April 2014 11:00pm


I am new to Linux. I tried to run Stepmania but I have failed.

I know that a huge amount of effort has gone into building the software, and documentation takes a long time too, so this message is really to anyone else in the community who might give me some simple pointers.

In my naivety, I was kind of hoping to drag the files to the desktop (I am using a Raspberry Pi), and double click on an executable icon.

Well I have done my best to uncompress the download, and a few other steps, but I can't figure out which is the actual executable bit - the main application.

Any (simple) pointers would be much appreciated - I'd love to get it running.

for ubuntu >=14.04 is needed (before the @Pemblem instalation process):

sudo apt-get install build-essential

sudo apt-get install libxrandr-dev freeglut3-dev libpng-dev libjpeg-dev gzip libmad0-dev libvorbis-dev vorbis-tools

it is not all, i am sorry because left behind other things, and i not remember.

once time, you have stepamania compilled, you will run stepmania, but works without sound.

Last edited: 19 April 2014 11:39am

Read my post above.
I don't know if this will run on Raspberry PI (I don't know anything about those things), but I imagine it will take a really long time to compile. The executable will be in the stepmania parent folder, make a shortcut.

I hope you can figure all that out. I didn't install the update XD

I wonder if it's a problem with ffmpeg. Shakesoda mentioned this package was old, and I noticed a lot of errors while compiling (although that's to be expected from a beta).

I've also noticed that this build of SM5 crashes a lot when playing songs with .avi backgrounds. At least they work now (usually) rather than having a weird color seizure in the background.

Last edited: 20 April 2014 9:06am