Forums » News » StepMania 5 beta 4a this weekend

Mac OS X 10.10 users: an update will be available over the weekend which fixes compatibility with the OS. For all other users it will be a very minor update, mostly fixing a few small compatibility issues with simfile background animations.
StepMania 5 beta 4a has been released.

This is a minor update of beta 4 that exists primarily for Mac OS X 10.10 users. If you've upgraded to the new OS X 10.10 and want to continue using SM5, you'll need to update!

Big thanks to GitHub user jberney for submitting the pull request that fixed this!

This build also fixes some BackgroundEffects errors, and adds some new NoteSkin metrics for themers to try out.


Last edited: 19 October 2014 8:49pm

Not sure if this is the best place to post this, but I'm still having a lot of (game breaking) issues with Beta 4a under Mavericks.

First, fullscreen is broken. In fullscreen, I can hear sound and can tell the game is running and receiving input, but all I see is a black screen. Everything shows up fine in windowed mode.

Secondly, and more importantly, the the game crashes when I try to play a song. Click "Show Spoiler" below to see the crash report.
You can probably see all this in the log, but I'm using an 11-inch, 2012 Macbook Air with an i7 processor, and Intel HD 4000 graphics. The crash report was generated was generated while I was using the default theme, although the problem appears to happen regardless.

Spoiler (click to view)
StepMania v5.0 beta 4a crash report (build 12, Sun Oct 19 20:50:22 EDT 2014 @ )


Architecture: Mac OS X (i386)
Crash reason: Assertion 'bSuccess' failed
Crashed thread: Main thread

Thread: GUI thread
Thread: Main thread
RageTextureManager.cpp:134 RageTextureManager::LoadTexture(/Themes/_fallback/Graphics/_blank.png).
BitmapText.cpp:155 BitmapText::LoadFromFont(/Themes/_fallback/Fonts/_open sans semibold 24px.ini)
FontManager.cpp:40 FontManager::LoadFont(/Themes/_fallback/Fonts/_open sans semibold 24px.ini).
IniFile.cpp:21 Reading 'Data/AI.ini'
PlayerAI.cpp:38 Assertion 'bSuccess' failed
Thread: Decode thread
Thread: Music thread
Thread: HAL I/O thread
Thread: Worker thread (MemoryCardWorker)
Thread: Worker thread (/@mc1int/)
Thread: Worker thread (/@mc2int/)
Thread: Input thread

002dcd1c: CrashHandler::ForceCrash(char const*)
00383dfd: sm_crash(char const*)
000bc42f: PlayerAI::InitFromDisk()
000a5a8e: Player::Player(NoteData&, bool)
000a5f80: Player::Player(NoteData&, bool)
001ad28c: PlayerInfo::Load(PlayerNumber, MultiPlayer, bool, int)
0047fedd: ScreenGameplayNormal::FillPlayerInfo(std::vector<PlayerInfo, std::allocator<PlayerInfo> >&)
005b80dd: luaM_realloc_
005c0bdf: setnodevector
005c0845: resize
0040659a: std::_Rb_tree<lua_State*, std::pair<lua_State* const, bool>, std::_Select1st<std::pair<lua_State* const, bool> >, std::less<lua_State*>, std::allocator<std::pair<lua_State* const, bool> > >::_M_erase(std::_Rb_tree_node<std::pair<lua_State* const, bool> >*)
001657ee: Actor::StopTweening()
00020ecb: RageMutex::Unlock()
00161059: Actor::InitState()
00161b30: Actor::Actor()
0017fe99: Model::Model()
000164f8: RageSound::RageSound()
00021b86: RageTimer::Touch()
001ad911: ScreenGameplay::ScreenGameplay()
001aeff5: ScreenGameplay::ScreenGameplay()
0047fddd: CreateScreenGameplayNormal(StdString::CStdStr<char> const&)
001cd4ba: ScreenManager::MakeNewScreen(StdString::CStdStr<char> const&)
001cea78: ScreenManager::PrepareScreen(StdString::CStdStr<char> const&)
00465e6d: ScreenSplash::HandleScreenMessage(StdString::CStdStr<char>)
001ce2a5: ScreenManager::SendMessageToTopScreen(StdString::CStdStr<char>)
00160226: Transition::UpdateInternal(float)
00164ee1: Actor::Update(float)
00171b85: ActorFrame::UpdateInternal(float)
00164ee1: Actor::Update(float)
00195cdb: Screen::Update(float)
001ce041: ScreenManager::Update(float)
0046acd8: GameLoop::RunGameLoop()
000deee2: SM_main
004a270b: -[SMMain startGame:]

Static log:
StepMania v5.0 beta 4a
Compiled Sun Oct 19 20:50:22 EDT 2014 @ (build 12)
Log starting 2014-10-20 12:25:29
Loading window: macosx
Model: MacBookAir5,1 (4/4)
Clock speed 2.00 GHz
Mac OS X Unknown
Memory: 8.00 GB
Sound driver: AudioUnit
Lights driver: SystemMessage
WARNING: Couldn't open Data/Translations.xml for reading: No such file or directory
WARNING: Couldn't open Data/Translations.xml for reading: No such file or directory
WARNING: Couldn't open Data/Translations.xml for reading: No such file or directory
Video renderers: 'opengl'
Paletted textures disabled: GL_EXT_paletted_texture missing.
WARNING: Error compiling shader Data/Shaders/GLSL/Texture matrix scaling.vert: No such file or directory
WARNING: Error compiling shader Data/Shaders/GLSL/Shell.frag: No such file or directory
WARNING: Error compiling shader Data/Shaders/GLSL/Shell.vert: No such file or directory
WARNING: Error compiling shader Data/Shaders/GLSL/Cel.frag: No such file or directory
WARNING: Error compiling shader Data/Shaders/GLSL/Cel.vert: No such file or directory
WARNING: Error compiling shader Data/Shaders/GLSL/Unpremultiply.frag: No such file or directory
WARNING: Error compiling shader Data/Shaders/GLSL/Color burn.frag: No such file or directory
WARNING: Error compiling shader Data/Shaders/GLSL/Color dodge.frag: No such file or directory
WARNING: Error compiling shader Data/Shaders/GLSL/Vivid light.frag: No such file or directory
WARNING: Error compiling shader Data/Shaders/GLSL/Hard mix.frag: No such file or directory
WARNING: Error compiling shader Data/Shaders/GLSL/Overlay.frag: No such file or directory
WARNING: Error compiling shader Data/Shaders/GLSL/Screen.frag: No such file or directory
WARNING: Error compiling shader Data/Shaders/GLSL/YUYV422.frag: No such file or directory
OGL Vendor: Intel Inc.
OGL Renderer: Intel HD Graphics 4000 OpenGL Engine
OGL Version: 2.1 INTEL-10.0.86
OGL Max texture size: 16384
OGL Texture units: 8
GLU Version: 1.3 MacOSX
OGL Extensions:
GL_APPLE: aux_depth_stencil, client_storage, element_array, fence, float_pixels, flush_buffer_range,
flush_render, object_purgeable, packed_pixels, pixel_buffer, rgb_422, row_bytes, specular_vector,
texture_range, transform_hint, vertex_array_object, vertex_array_range, vertex_point_size,
vertex_program_evaluators, ycbcr_422
GL_ARB: color_buffer_float, depth_buffer_float, depth_clamp, depth_texture, draw_buffers,
draw_elements_base_vertex, draw_instanced, fragment_program, fragment_program_shadow, fragment_shader,
framebuffer_object, framebuffer_sRGB, half_float_pixel, half_float_vertex, instanced_arrays, multisample,
multitexture, occlusion_query, pixel_buffer_object, point_parameters, point_sprite, provoking_vertex,
seamless_cube_map, shader_objects, shader_texture_lod, shading_language_100, shadow, sync,
texture_border_clamp, texture_compression, texture_compression_rgtc, texture_cube_map, texture_env_add,
texture_env_combine, texture_env_crossbar, texture_env_dot3, texture_float, texture_mirrored_repeat,
texture_non_power_of_two, texture_rectangle, texture_rg, transpose_matrix, vertex_array_bgra, vertex_blend,
vertex_buffer_object, vertex_program, vertex_shader, window_pos
GL_ATI: separate_stencil, texture_env_combine3, texture_float, texture_mirror_once
GL_EXT: abgr, bgra, blend_color, blend_equation_separate, blend_func_separate, blend_minmax, blend_subtract,
clip_volume_hint, debug_label, debug_marker, draw_buffers2, draw_range_elements, fog_coord, framebuffer_blit,
framebuffer_multisample, framebuffer_multisample_blit_scaled, framebuffer_object, framebuffer_sRGB,
geometry_shader4, gpu_program_parameters, gpu_shader4, multi_draw_arrays, packed_depth_stencil, packed_float,
provoking_vertex, rescale_normal, secondary_color, separate_specular_color, shadow_funcs, stencil_two_side,
stencil_wrap, texture_array, texture_compression_dxt1, texture_compression_s3tc, texture_env_add,
texture_filter_anisotropic, texture_integer, texture_lod_bias, texture_rectangle, texture_sRGB,
texture_sRGB_decode, texture_shared_exponent, timer_query, transform_feedback, vertex_array_bgra
GL_NV: blend_square, conditional_render, depth_clamp, fog_distance, light_max_exponent, texgen_reflection,
GL_SGIS: generate_mipmap, texture_edge_clamp, texture_lod
OpenGL Windowed 1570x883 32 color 32 texture 60Hz Vsync SmoothLines
WARNING: Couldn't initialize device.
Mixing underruns: 1
Players joined: P1
Top Screen: ScreenStageInformation
Language: en
Current renderer: OpenGL
Theme: default

Partial log:
00:31.683: glTexImage2D (format GL_RGBA8, 512x128, format GL_RGBA, type GL_UNSIGNED_BYTE, pixfmt 0, imgpixfmt 0)
00:31.683: RageBitmapTexture: Loaded '/Themes/default/Graphics/_rave result P1.png' (512x128); RGBA8, source 512,128; image 512,128.
00:31.686: glTexImage2D (format GL_RGBA8, 512x128, format GL_RGBA, type GL_UNSIGNED_BYTE, pixfmt 0, imgpixfmt 0)
00:31.687: RageBitmapTexture: Loaded '/Themes/default/Graphics/_rave result P2.png' (512x128); RGBA8, source 512,128; image 512,128.
00:31.690: glTexImage2D (format GL_RGBA8, 512x128, format GL_RGBA, type GL_UNSIGNED_BYTE, pixfmt 0, imgpixfmt 0)
00:31.690: RageBitmapTexture: Loaded '/Themes/default/Graphics/_rave result draw.png' (512x128); RGBA8, source 512,128; image 512,128.
00:31.693: Loading /Themes/default/Sounds/default/_Screen cancel.ogg, type FileType_Sound
00:31.693: RageSound: Load "/Themes/default/Sounds/default/_Screen cancel.ogg" (precache: 1)
00:31.694: ScoreDisplayNormal::ScoreDisplayNormal()
00:31.696: Reading 'Data/AI.ini' failed: No such file or directory

-- End of report
Something went wrong when Stepmania tried to load Data/AI.ini to set the AI skill level. Check whether that file exists and can be read.
< cybik> til Kyzentun fixes bugs for breakfast
< maxvg1> shakesoda: then why do i still play lol
<@shakesoda> because you're an ITG player. And thus, a masochist
<@shakesoda> Kyzentun: I think you might need to put down the meshes for a bit
Should have mentioned this in the original post, but I already checked that. The file does indeed exist and I can open it fine in TextEdit. Doesn't seem to have any abnormal permissions either.
Fullscreen on OS X was broken when we moved the Xcode project from 10.6 SDK to the 10.9 SDK (this commit). Upgrading the SDK allowed us to continue to build SM5 for OS X at all (a good thing!) but fullscreen support was lost along the way. From what I gather, SM's fullscreen code was a custom job, written before OS X natively supported fullscreen apps (like, OS X 10.3), and utilized API calls that no longer exist.

Generally speaking, the OS X-specific code is woefully under-maintained and out-of-date. If you know Objective-C, pull requests are very, very welcome. Alternatively, help move window-management code to SDL if you know that.

I'm not sure what to say about ./Data/AI.ini
I downloaded a clean copy of beta4a just now, started up with default theme, and played a couple songs (one myself, one on Autoplay, one on AutoplayCPU) and didn't crash. Where do you have your StepMania-v5.0-beta-4a directory installed to?

Judging by your error report in the other thread, I'm going to assume you installed to /Applications/ . Can you try installing within your home directory?

Last edited: 20 October 2014 11:03am

Thanks, that pushed me in the direction of figuring out how to solve the problem: I had in the Applications folder and everything else in ~/Library/Application Support/Stepmania. Moving everything into the same folder fixed the problem.

For some reason, I'd actually thought my previous method was how it was supposed to be done. Not sure why, although it always worked pre-Yosemite.
For what it's worth, I am completely unable to replicate this problem! >_>