Forums » General Questions » Stepmania won't open - not configured correctly?

I have Stepmania on both my desktop and laptop. It works fine on my desktop, on my laptop it won't open, when I try to open it it shows an error message saying something about the program not being configured correctly, and to try reinstalling. I initially installed it from the setup file I put on a flash drive, I tried re-adding the file to the flash drive and running it from there, same message popped up. So I downloaded it directly from the website onto my laptop and it still said the same thing. It's a Dell Inspiron 1300 running Windows XP with 1 GB of RAM. I can get the exact error message if needed.
The one error message that i'm aware of says that d3dx9_35.dll is missing and that you need to reinstall.
If you are getting this error, you simply need to install directx 9 or higher on your laptop, no reinstallation of the game required.

If not then i am curious to know what it says.
Read the FAQ and install the MSVC runtimes.
I installed DirectX 9, Microsoft Visual C++ 2010 redistributable (I think that's what's on my desktop), and Microsoft .NET framework 4. Uninstalled Stepmania, rebooted, reinstalled Stepmania, and I still receive the message. I originally installed it in C:\Games, Program Files still doesn't work. Here's the message:

Error Message

EDIT: Stepmania 4 Aplha 4 works fine, apparently it's some new feature causing the issue.
EDIT2: MSVC 2013 doesn't change anything either.

Last edited: 5 August 2015 7:54pm

Try 2012.
No dice.

I don't get why an older version would work and not 5. What's so new?

Is it just my graphics card or something?

I could just use alpha 4, but my double maps don't work. I have a double and a single in one SM file, do they need to be separate? Also, is there anywhere I can download other versions? Like a non-alpha 4? I seem to only have Dance as a game mode, nothing else. I'd like a version with more, or can I add them to the alpha?
Is a little bumping allowed or should I make another thread?
Bumping is fine.
I have no idea what might be going wrong. Try searching the internet for the error message. Try different versions, like 5.0.6 or 5.0.7 or so on, which are all on the github releases page if you scroll down.
I think XP is no longer supported, in part because nobody uses XP. jindev might have managed to make it work for him by building from source, but I can't remember clearly.
< cybik> til Kyzentun fixes bugs for breakfast
< maxvg1> shakesoda: then why do i still play lol
<@shakesoda> because you're an ITG player. And thus, a masochist
<@shakesoda> Kyzentun: I think you might need to put down the meshes for a bit